[Solved]Para-1 Test-Add a worker to a pool index 88, error 14

From TG Miner group


Question:I am trying to add a worker to a pool at Console for the new para-1 testnet. The extrinsic never completes and no worker is added. Other operations like setting cap, etc. work fine…

phalaStakePool.addWorker extrinsic still failling… Anybody knows what to make out of index: 88, error: 1 ?

looks to me like other pools are having the same issue… perhaps something worth looking into

i tried again just now and addWorker went through… but, now phalaStakePool.startMining is failing with index 88, error 14

This was me posting the issue on Telegram. Thank you for reposting it here.

The problem (I think) was that I the pool had 0 staking. I staked some tokens and I started receiving index 88, error 13, however, after trying a few times, it worked.

Seems like the behavior is not stable, i.e. with both addWorker and startMining, I had to submit the same extrinsic a few times with no changes in the setup, to make it work. I also noticed the same was happening for other miners on the chain.

Thanks